Erreur 500 site Drupal chez 1and1

Répondre
plumpcat
Messages : 12
Enregistré le : jeu. 1 janv. 2009 13:00

Erreur 500 site Drupal chez 1and1

Message par plumpcat » mer. 13 nov. 2013 08:29

Depuis plusieurs jours j'obtiens systématiquement une erreur 500 (Internal Server Error) sur mon site http://www.charon.fr développé avec Drupal.
J'ai contacté la Hotline de mon hébergeur (1and1) et ils ne trouvent aucun problème de serveur.
Je sèche totalement !

plumpcat
Messages : 12
Enregistré le : jeu. 1 janv. 2009 13:00

Re: Erreur 500 site Drupal chez 1and1

Message par plumpcat » mer. 13 nov. 2013 08:36

J'ai trouvé et je me réponds... cela peut servir !

La Hotline 1and1 aurait pu me mettre sur la piste mais ils n'ont pas eu le réflexe de contrôler l'état de ma base de données.
Elle faisait 128 Mo pour un quota autorisé à 100 Mo.
Pourquoi fait-elle 128 Mo ??? Je verrais cela plus tard ...

Dans l'immédiat, j'ai vidé toutes les tables ...cache... de Drupal ainsi que la table watchdog.
Ma base est alors revenue à un niveau acceptable de 40 Mo - je dis acceptable car je trouve cela encore trop.

J'ai ensuite commenter la ligne Options +FollowSymLinks dans le fichier .htaccess

Et voilà ! le site est de retour parmi le monde réel.

plumpcat
Messages : 12
Enregistré le : jeu. 1 janv. 2009 13:00

Re: Erreur 500 site Drupal chez 1and1

Message par plumpcat » mer. 13 nov. 2013 08:38

J'ai parlé trop vite !!!
Le site est encore en vrac.

La faute ? Toujours à la base de données et surtout à Drupal.
Bon je recommence mes manipulations de vidage de table et je vais chercher une solution pour brider le cache Drupal.

A suivre ...

marco44
Administrateur du site
Messages : 86
Enregistré le : jeu. 1 janv. 2009 13:00

Re: Erreur 500 site Drupal chez 1and1

Message par marco44 » mer. 13 nov. 2013 08:40

Sujet transféré vers le forum Drupal.

plumpcat
Messages : 12
Enregistré le : jeu. 1 janv. 2009 13:00

Re: Erreur 500 site Drupal chez 1and1

Message par plumpcat » mer. 13 nov. 2013 09:12

Je tente de limiter la taille de la table cache_form à l'aide du module OptimizeDB.

En effet, en y regardant de plus près, cette table fait à elle-seule 75 Mo !!!

Toujours à suivre...

Répondre